0

آشنایی با InterVlan Routing و راه اندازی مفهوم ROAS با روتر و سوئیچ

آشنایی با InterVlan Routing و راه اندازی مفهوم ROAS با روتر و سوئیچ

پیکربندی Inter VLAN در سوئیچ و روتر سیسکو را زمانی انجام میدهیم که ما یک شبکه و یک سری VLAN هایی داریم و میخواهیم این VLAN ها بتوانند با یکدیگر در ارتباط باشند.

یک سوئیچ لایه دو میتواند با اتصال به یک روتر ارتباط بین VLANها را برقرار کند ، این ارتباط میتواند با استفاده از لینک های جداگانه برای هر VLAN بین سوئیچ و روتر انجام گردد و یا با استفاده از یک لینک Trunk از سوئیچ به روتر.

 

اگر چه میتوان برای هر VLAN از سوئیچ به روتر یک لینک برقرار کرد ،اما با توجه به اینکه تعداد پورت های روتر محدود میباشد بهترین راهکار برقراری یک لینک Trunk بین سوئیچ و روتر است ولی باید به این نکته توجه داشت که Trunking یک پروتکل لایه دو می باشد. پس نمیتوان پورت روتر را Trunk کرد ، راه کار این است که از Subinterface  در کنار دستور encapsulation dot1q استفاده کرد که در ادامه بیشتر توضیح داده خواهد شد.

 

 

 

inter vlan routing

 

روش فوق کلا روشی قدیمی میباشد و امروزه کاربردی ندارد.

 

پس از VLAN بندی شبکه و قراردادن پورت‌های سوئیچ در داخل VLAN های مربوط بایستی ارتباط بین VLANها یا به عبارتی Inter-VLAN Routing را نیز راه‌اندازی کنیم. باتوجه به اینکه هر VLAN یک broadcast domain مستقل به شمار می‌آید و بین این broadcast domainها ارتباط سوئیچینگ کاربرد ندارد بایستی برای دسترسی VLANها به یکدیگر بین آن‌ها routing راه‌اندازی شود.

نکته ابتدایی که در خصوص Inter-VLAN routing وجود دارد، عدم درک VLAN توسط router می‌باشد. با علم به این موضوع که روتر درکی از VLAN ندارد، پس چگونه می‌تواند ترافیک بین VLAN ها را مدیریت کرده و عبور دهد؟

 

روتر در حالی که درکی از VLAN ندارد و ترانک را متوجه نمی‌شود، اما ویژگی ایی دارد که می‌تواند header لایه ۲ ایی را که باز کند و encapsulation را متوجه شود. در صورت وجود tag مربوط به encapsulation اطلاعات را مربوط به VLAN در نظر می‌گیرد.

 

برای انجام تنظیمات روتر به منظور تفهیم ارتباطات VLAN بایستی پورتهای مجازی (راه‌اندازی پورت یا اینترفیس به ازای هر VLAN) راه‌اندازی کنیم. به این پورت‌های مجازی subinterface گفته می‌شود.

 

برای ایجاد suninterface از دستور interface fastethernet x/x.VLAN Number که VLAN-Number هر عددی از ۱ تا ۱۰۰۵ می‌تواند باشد. بهتر است برای واضح‌تر بودن تنظیمات بهتر از عدد مساوی با VLAN مربوط استفاده کنیم. پس از اعمال دستور به محیط subinterface می‌رویم. در این محیط می‌توانیم پس از مشخص‌کردن encapsulation ترافیک، تعیین می‌کنیم این subinterface مربوط به کدام VLAN می‌باشد.

 

 

 

و پس از مشخص کردن IP مربوط دستور no shut را برای subinterface اعمال می‌کنیم تا پورت مجازی up شود.

نکته: تمامی پورتهای distribution switch بایستی به حالت ترانک برده شوند تا بتوانند ترافیک بین VLAN ها و routing را مدیریت کنند. (حتی پورتی که به روتر متصل است)

 

مثال : طبق تصویر زیر می خواهیم کامپیوتر واقع در VLAN 10 بتواند با کامپیوتر واقع در VLAN 20 ارتباط بر قرار نماید.

برای حل مورد فوق سه راه کار داریم:

  • Traditional Method
  • Router on stick
  • Inter VLAN in layer 3 switch

 

روش اول : روش قدیمی ( Traditional Method ) که همانطور دیگر کاربردی ندارد.

 

 

در توپولوژی فوق بروش قدیمی عمل کرده ایم ، یعنی اینکه برای اتصال سوئیچ به روتر از دو اینترفیس استفاده نموده ایم.

 

 

روش دوم : ( Router on a stick )

 

 

 

مثال :

 

 

 

دستورات زیر را بر روی سوئیچ می نویسیم :

 

دستورات مربوط به ایجاد VLAN بر روی سوئیچ :

Switch(config)#vlan 10

Switch(config-vlan)#vlan 20

Switch(config-vlan)#exit

 

دستورات مربوط به اینترفیس سوئیچ ناحیه سبز رنگ :

Switch(config)#in f0/1

Switch(config-if)#switchport mode access

Switch(config-if)#switchport access vlan 10

Switch(config-if)#exit

دستورات مربوط به اینترفیس سوئیچ ناحیه زرد رنگ :

Switch(config)#interface f0/2

Switch(config-if)# switchport mode access

Switch(config-if)#switch access vlan 20

Switch(config-if)#exit

دستورات مربوط به Trunk  کردن سوئیچ :

Switch(config)#interface g0/1

Switch(config-if)#switchport mode trunk

 

 

 

مجموعه دستورات لازم بر روی روتر :

Router(config-if)#interface g0/0.10

Router(config-subif)#encapsulation dot1Q vlan 10

Router(config-subif)#ip address 192.168.10.1 255.255.255.0

Router(config-subif)#exit

Router(config)#interface g0/0.20

Router(config-subif)#encapsulation dot1Q 20

Router(config-subif)#ip address 192.168.20.1 255.255.255.0

 

 

حال تست ارتباط می گیریم :

 

 

همانطور که ملاحظه می کنید توانستیم از سیستم PC0 واقع در VLAN 10 به PC1 واقع در VLAN 20 بسته هایی ارسال نماییم.

 

 

روش سوم : Inter VLAN با سوئیچ لایه ۳

 

به طور معمول برای مدیریت کردن routing بین VLANها از سوئیچ لایه۳ در لایه۳ یا لایه core استفاده می‌شود.

 

 

 

مثال :

 

 

 

 

 

در سوئیچی که در تصویر به سیستم ها کلاینت متصل است نیاز است ابتدا پورت بین خودش و سوئیچ لایه سه را Trunk کنیم

Switch#configure terminal
Switch(config)#int gigabitEthernet 0/1
Switch(config-if)#switchport mode trunk

سپس پورت هر کلاینت را عضو VLAN مورد نظرمان میکنیم

Switch(config)#int fastEthernet 0/1
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 10
Switch(config-if)#exit
Switch(config)#int fastEthernet 0/2
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 20
Switch(config-if)#exit

سپس در سوئیچ لایه سه ابتدا پورتی که به سوئیج مقابل متصل است را به صورت زیر در حالت ترانک تنظیم میکنیم

Switch>en

Switch#configure terminal

Switch(config)#int gigabitEthernet 0/1

Switch(config-if)#switchport trunk encapsulation dot1q

Switch(config-if)#switchport trunk encapsulation dot1q

بعد Interface VLAN های مد نظرمان را میسازیم و به آنها ایپی میدهیم

Switch(config)#interface vlan 10

Switch(config-if)#no shutdown

Switch(config-if)#ip address 192.168.10.1 255.255.255.0

Switch(config-if)#exit

Switch(config)#interface vlan 20

Switch(config-if)#no shutdown

Switch(config-if)#ip address 192.168.20.1 255.255.255.0

Switch(config-if)#exit

فقط باید دقت داشت که این دو اینترفیس ما down است چرا که  VLAN 10 و ۲۰ اصلا وجود ندارند تا انها UP شوند پس با دستور زیر VLAN ها را میسازیم تا Interface VLAN هایمان UP  شوند

Switch(config)#vlan 10

Switch(config-vlan)#exit

Switch(config)#vlan 20

Switch(config-vlan)#exit

با دستور زیر نیز میتوان وضعیت اینترفیس های خود را ببینیم

Switch#show ip interface brief

و در نهایت برای اینکه قابلیت Routing روی سوئیچ لایه سه ای فعال شود باید دستور زیر را استفاده کرد

Switch(config)#ip routing

 

 

مهدی مصدق

ارسال دیدگاه

نشانی ایمیل شما منتشر نخواهد شد. بخش‌های موردنیاز علامت‌گذاری شده‌اند *